Unable to mount FAT16 partition (Invalid Argument)

JD jd1008 at gmail.com
Mon Mar 25 16:47:41 UTC 2019

On 03/25/2019 10:25 AM, Peter Erickson wrote:
> While the partition is only 250M, anything is worth a shot at this 
> point. Unfortunately, that didn't work either - same result. I'm glad 
> that I'm not the only one that's stumped.
> # mount -t msdosfs -o ro,large /dev/ada1p5 /mnt
> mount_msdosfs: /dev/ada1p5: Invalid argument
> On 3/25/19 9:21 AM, Andrea Venturoli wrote:
>> On 3/25/19 2:42 AM, Peter Erickson wrote:
>>> I'm hoping to get some assistance mounting a FAT (FAT16?) partition 
>>> created by the VMware ESXi installer (version 6.7.0). Every attempt 
>>> to mount it on 11.2-RELEASE-p4, results in an "Invalid argument" 
>>> error, without much to indicate what is wrong or how to resolve it. 
>>> Any advice or direction would be much appreciated.
>> I've had this problem in the past and solved using "-o large".
>> According to the man page this shouldn't be your case (and I don't 
>> remember how big a partition I was trying to mount), but, for the 
>> price, it's worth trying :)
>> HTH.
>>   bye
Assuming the device you entered (ada1p5) is the device in question,
have you tried the option  -o fat   instead of msdosfs ?

Also, again assuming the device name is as you entered, have you tried
dd if=/dev/ada1p5 of=/dev/null bs=1M count=10
and see what error mesage(s) you get.

More information about the freebsd-questions mailing list