Unable to mount FAT16 partition (Invalid Argument)

Polytropon freebsd at edvax.de
Mon Mar 25 09:34:46 UTC 2019

On Sun, 24 Mar 2019 20:42:30 -0500, Peter Erickson wrote:
> # mount -t msdosfs /dev/ada1p5 /mnt
> mount_msdosfs: /dev/ada1p5: Invalid argument

I have no idea if this applies, but I can imagine that FAT and GPT
don't work well together. GPT is "too new", and even on "Windows"
where GPT can be used, NTFS is used instead of FAT16. A FAT filesystem
is usually created on a DOS primary partition (a slice). A GPT
partition is something else...

Sidenote: For testing, always use -o ro or -r to make sure no
writes are allowed (or tried). Sometimes this allows you to mount
even damaged file systems. Try one of these:

	# mount -t msdosfs -r /dev/ada1p5 /mnt

	# mount_msdosfs -o ro /dev/ada1p5 /mnt

The use of "mount -t msdosfs" and "mount_msdosfs" should be equivalent.
See "man mount_msdosfs" for details.

> FWIW, knoppix has no issues mounting the partition, but I'd really be 
> interested in getting this to work on FreeBSD.
> knoppix # mount | grep /dev/sdb5
> /dev/sdb5 on /mnt type vfat 
> (rw,relatime,fmask=0022,dmask=0022,codepage=850,iocharset=utf8,shortname=mixed,errors=remount-ro)
> Based on the info from knoppix, I tried to mount the partition under 
> FreeBSD using mount_msdosfs directly and specifying the locale 
> (en_US.UTF-8) and codepage (CP850) , but the result was the same - 
> "Invalid argument."

Locale and codepage shouldn't have an effect on the basic mount
operation. Both are fairly standard and should be covered by the
defaults anyway.

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list