Ignoring /boot/loader.conf and /boot/loader.conf.local?

Polytropon freebsd at edvax.de
Tue Mar 19 13:56:30 UTC 2019

On Tue, 19 Mar 2019 12:56:05 +0000, Witzel, Stefan wrote:
> Hi,
> on a system running FreeBSD 12.0 I want to run MongoDB (in a jail).
> According to https://vermaden.wordpress.com/tag/mongodb/ I tried to
> increase kern.maxproc.
> The default value was 99999. For testing purposes I first add
> kern.maxproc=100000
> to /boot/loader.conf and rebooted: the value has not changed; the
> same result editing /boot/loader.conf.local.
> Only if I edit /boot/defaults/loader.conf the value changed to 100000.

You should not change a defaults file, this is not intended.

> Are there other restrictions on kern.maxproc?

Did you try setting those vial /etc/sysctl.conf?

> Later I found all other entries in /boot/loader.conf are also ignored.

That looks very strange. But it might be due to the jail
construction which inherits the kernel values from the host...

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list