Upgraded 11.2 -> 12.0, ntpd Won't Start

B J va6bmj at gmail.com
Sat Mar 16 22:39:10 UTC 2019

On 3/15/19, B J <va6bmj at gmail.com> wrote:
> Before I did the upgrade, I ran ntpd by putting
> ntpd_enable="YES"
> in:
> /etc/rc.conf
> Now, when I boot my computer, I get:
> Security policy loaded: MAC/ntpd (mac_ntpd)
> Starting ntpd.
> su: unknown login: ntpd
> /etc/rc: WARNING: failed to start ntpd
> The upgrade to 12.0 was done with the following:
> freebsd-update fetch
> freebsd-update install
> freebsd-update -r 12.0-RELEASE upgrade
> I restarted the machine and ran:
> /usr/sbin/freebsd-update install
> when prompted to do so.  I also reinstalled all the packages and, I
> believe, ports.  I didn't, however, run mergemaster or:
> pwd_mkdb -p /etc/master.passwd
> nor do I recall being prompted to do so during the upgrading process.
> (Maybe I wasn't paying attention.)
> Can I get ntpd to run if I ran:
> pwd_mkdb -p /etc/master.passwd


Thanks to everyone who responded.  Your comments and suggestions were
most helpful.

I ran:

pwd_mkdb -p /etc/master.passwd

on one of my computers and rebooted it when it was done.  I got the
following message in the startup output:

ntpd[755]: pid file /var/db/ntp/ntpd.pid: Permission denied

I checked the file and found that the file has the number 789 in it.

By comparison, I have two systems that have fresh installations of
FreeBSD 12.0.  Neither of them had the problem with ntpd that I
mentioned in my original post.  I just checked the file on one of them
and found that it has the number 885.

My question, now, is this:  is the condition mentioned in the message
I got on the upgraded machine a problem?  Is the difference in the
ntpd.pid files something to be concerned about?

Meanwhile, the computer's clock appears to be running properly as I
reset my watch and the both are synchonized, so it seems that problem
has been resolved.



More information about the freebsd-questions mailing list