USB "video grabber" input selection

Polytropon freebsd at
Tue Jul 2 12:18:59 UTC 2019

To prepare an amateur TV streaming experiment, I'm currently
trying to get a "video grabber" to work with my camera, which
will later be replaced by a satellite receiver output. The
signal is regular (composite) video. I have verified the signal
to be a normal video signal with the TV card's video input in
my old PC, so that works. Now my intention is to use the webcam
intrastructure (webcamd, pwcview) for testing.

The video grabber has the following connectors:

	- dual cinch L / R for audio input
	- yellow cinch for composite video input
	- 4-pin mini-DIN plug for S-video input
	- USB connector for digital video output
	- 2.5mm stereo jack for analog audio output

When attached to the system (FreeBSD 12.0-p6/i386), the following
entry is created:

	ugen2.5: <vendor 0xeb1a product 0x2800> at usbus2

I can then go ahead and test the two video inputs, assuming they
are numbered 0 and 1:

	# webcamd -d ugen2.5 -i 0 -v 0
	Attached to ugen2.5[0]
	Creating /dev/video0
	% pwcview -d /dev/video0
	Webcam set to: 320x240 (sif) at 5 fps

This results in a totally distorted and blurry image (like "lost
synchronisation"). However, when I wave my arm into the camera, I
can see a change in the pattern. However, I must connect the camera
with a cinch->S-video adapter to the S-video input to get a picture.

And for the 2nd input:

	# webcamd -d ugen2.5 -i 0 -v 1
	Attached to ugen2.5[0]
	Creating /dev/video1
	% pwcview -d /dev/video1
	Webcam set to: 320x240 (sif) at 5 fps

In this case, I only get a black ("empty") window. No signal. But
if I disconnect the video camera and re-connect it to the S-video
input (with the adapter as mentioned above), I get the blurry image

I went ahead and tried inputs 2, 3, 4, ... 10, same result. So no
matter which video input I specify, only the S-video input is used.
I did read "man webcamd" and "man pwcview", and I think the commands
shown above should be okay. Varying webcamd's -i parameter does not
help, it leads to an error message:

	# webcamd -d ugen2.5 -i 1 -v 0
	webcamd: Cannot find USB device

Sidenote: With webcamd, I got a boring 20 years old webcam working,
so is _basically_ works.


How do I tell the video grabber to use the composite video input?

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list