[SOLVED]: Cannot print from mate desktop

Polytropon freebsd at edvax.de
Wed Jan 30 18:29:36 UTC 2019

On Wed, 30 Jan 2019 11:02:13 -0500, James B. Byrne via freebsd-questions wrote:
> On Tue, January 29, 2019 16:18, James B. Byrne wrote:
> >
> >
> > On Tue, January 29, 2019 15:49, James B. Byrne wrote:
> >> FreeBSD-11.2p8
> >>
> >> Following a massive pkg update this morning, followed by
> >> a freebsd-update install and restart, I now discover that
> >> I cannot print from the mate desktop.  When I print from
> >> any application on the desktop, libreoffice, pluma, firefox,
> >> the printer dialogue shows up, the print job is generated,
> >> but nothing prints on the printer.  Nor can I find any
> >> printer management applet in the toolbar.
> >>
> The problem of failing to print was solved by (re-?)installing the
> cups-filters package.  Which is somewhat troublesome since it seems
> that package, or its functional equivalent, was installed before the
> upgrade and was removed thereby.

Exactly my guessing. :-)

I've seen this in the past - a re-install of CUPS and its
related packages solved the printing problem. The primary
indication of what's wrong can be found in the error log.
Sometimes, functionalities will "shift", i. e., packages
get combined, integrated, or removed, and a re-install
will solve the "open ends" problem.

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list