UEFI loader picking wrong native resolution, documented fixes don't work

Mel Pilgrim list_freebsd at bluerosetech.com
Thu Jan 17 09:00:23 UTC 2019

When my system boots, the UEFI loader chooses a resolution of 1600x1200, 
but the connected monitor only supports up to 1280x1024.  My 
understanding is that the UEFI loader picks the native resolution, so 
I'm puzzled why it isn't working.

The system is a Supermicro X11SSH-LN4F with a Xeon E3-1245 v6.  FreeBSD 
11.2.  The remote console works fine.

Here's a list of everything I've tried adding to /boot/loader.conf:

gop set N
exec gop set N
mode N
exec mode N

I tried values of 0 through 4 for N.  None of it worked (the console 
remains at 1600x1200).  If I escape to the loader, I can manually type 
"mode 2" and the loader will switch to, and the console will stay at 
800x600.  Oddly, only that and "mode 3" (1600x1200) work.  Modes 0 and 1 
produce broken results where the resolution switches, but the console 
doesn't use the entire screen.



causes the loader to hang after displaying:

Start @ 0xffffffff80310000 ...
EFI framebuffer information:
addr, size     0xde000000, 0x753000
dimensions     1600 x 1200
stride         1600
masks          0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000

requiring a hard reset.

I tried building and install graphics/drm-next-kmod so that I could load 
i915kms.ko that supports Kaby Lake, but it causes a panic when the DRM 
probe happens.

Is this is some quirk of the IPMI-enabled console returning bad 
capabilities when vt probes the display?

Is anyone else running FreeBSD 11 on a Supermicro X11SSH with integrated 
graphics and having this problem?

How do I tell the vt console to use a different resolution?

Am I just screwed and now have to buy a new head unit that can do 1600x1200?

More information about the freebsd-questions mailing list