Synaptics on Panasonic Touchbook CF-C2

Tomasz CEDRO tomek at
Thu Jan 3 22:59:00 UTC 2019

On Wed, Jan 2, 2019 at 12:27 PM Greg V wrote:
> On Wed, Jan 2, 2019 at 3:30 AM, Tomasz CEDRO <tomek at> wrote:
> > Hello world in 2019 :-)
> >
> > I cannot make my Touchpad two finger scrolling on CF-C2 Panasonic
> > Toughbook. It works on Windows very nice. I have made it work only
> > once in Xorg but never again..
> >
> > I have tried on 11.2 and 12.0. Both with PSM+MOUSED and
> > PSM0+SYNAPTICS. No success.
> >
> > As I understand, the old way was to use xf86-input-synaptics. The new
> > way is to use PSM with synaptics support enabled and then use moused +
> > xf86-input-mouse..?
> >
> > I would like to stick to the new way of using PSM kernel driver, then
> > moused and sysmouse as mouse input for Xorg.
> >
> > The problem is that both PSM nor SYNAPTICS does not seem to recognise
> > the device. I get ID 0 for PSM. Tried various flags. No success..
> Make sure you have hw.psm.synaptics_support=1 in /boot/loader.conf
> moused is *not* the new way. Forget moused, disable it completely, it is
> designed only for basic mice, it will never work with touchpads'
> advanced capabilities.
> The new way is evdev/libinput. Unfortunately evdev wasn't enabled by
> default in
> 12.0-RELEASE, I think you have to switch to 12-STABLE snapshots at least
> (or rebuild a 12 kernel manually).

Thank you Greg for response.. I guess it the moused+psm is not the
default/new way we could update the wiki/documentation.. this kind of
scrolling interaction is mandatory after anyone ever worked on a
MacBookPro Prackpad :-) I even made Wacom touchscreen and pen working
on that laptop which is really neat.. so how sad not to have basic two
finger scroll..

Sure I have tried with hw.psm.synaptics_support="1" but then I have no
mouse at all even in the VT console using moused. Debugging PSM at
level 2 does not seem to produce different results - each time I get
the same data, which would confirm why mouse cursor is not moving..
but what is the cause of such PSM TrackPad stall?

I guess I have exhausted all possible permutations of MOUSED PSM
SYNAPTICS X11 w/oHAL w/oAutoAddDevices :-(

I have also noticed libinput but had no luck with that either..

What is very interesting that on my other desktop machine that I am
playing with AMDGPU I have Microsoft wireless keyboard with Touchpad
included.. and that touchpad worked right from scratch after plugging
in the USB micro receiver :\

I noticed lots of positive comments about out-of-the-box support for
Trackpad in OpenBSD and NetBSD.. it would be really nice if we also
had that kind of support in FreeBSD :-)

Best regards :-)


More information about the freebsd-questions mailing list