Lost net connection

Polytropon freebsd at edvax.de
Fri Aug 30 08:36:51 UTC 2019

On Fri, 30 Aug 2019 09:00:09 +0200, 76nemo76 wrote:
> Hi All,
>       I have a freebsd 12 machine connected to a network switch.
> The network switch is sometime switched off and on again
> (but not the FreeBSD machine)  and
> then the network is lost on the freebsd machine.
> I have tried a lot of commands (ifconfig for instance) to restart the network
> without any success. Only a reboot makes the network working again.
> I should mention that the machine has 4 ethernet ports
> used in a bridge (all the ethernet ports are in the bridge)
> Do you have any idea?

It sounds like faulty networking equipment, maybe the FreeBSD
machine's internal NIC? If the switch is off, does "ifconfig"
output still say "status: active", or "status: no carrier"?

However, you should be able to restart the network without a
reboot, using the following command (as root):

	# service netif restart

What manufacturer is the NIC? Maybe Realtek? I once had a
similar problem with a Realtek NIC: After re-connecting, it
did still insist on "no carrier", but after "service netif
restart", it worked again... :-)

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list