Solved. Re: Dualboot and ZFS

Warren Block wblock at
Wed Mar 21 12:27:38 UTC 2018

On Mon, 19 Mar 2018, Victor Sudakov wrote:

> On 2018-01-31 08:27, Victor Sudakov wrote:
>>> My pool works successfully in a bhyve environment, but in VirtualBox
>>> 5.0.14
>>> (to test the real boot sequence) I get this message from zfsboot:
>>> zfsboot: No ZFS pools located, can't boot
>>> However, if I boot from LiveCD, the pool is there, it's healthy and
>>> can be imported.
> Finally, and thanks to Eugene Grossbein, the problem is solved.
> The gist of the problem was the presence of a BSD label in the slice
> where the bootable zfs pool was located. It turns out that zfsboot
> ignores the slice if it finds a BSD label therein. The bootable zpool
> should be directly on the slice (like on da1s1, and not da1s1a).
> This means that both zfsboot(8) and the articles in the FreeBSD wiki
> are erroneous because they all suggest "gpart create -s BSD ada0s1" -
> in fact, it's fatal.
> Below is the final working example:
> ================================================
> #!/bin/sh
> sysctl kern.geom.debugflags=0x10

Please reconsider doing this without it being required.  It means "allow 
destroying mounted partitions" and is usually not necessary.

More information about the freebsd-questions mailing list