Intel 82598EB twinax cables

Dean E. Weimer dweimer at
Tue Mar 20 22:46:55 UTC 2018

On 2018-03-20 5:44 pm, Mark Kane wrote:
> On 2018-03-20 16:12, Dean E. Weimer wrote:
>> I am trying to utilize an old Dell R710 server that used to be in our
>> ESX cluster. To replace an even older FreeBSD server I have been
>> running. Because it's pretty stupid to throw massively better system
>> in the recycle pile while keeping the slower system online.
>> The problem I have is that the new server has 10G Ethernet adapters
>> connected with Cisco Twinax Cables.
>> Adapters are Intel 8259EB 10Gigabit AF Dual Port Adapters
>> We have Cisco Twinax Cables connecting them to an Avaya VSP 7000 
>> series switch
>> However I have been unable to get the interfaces to show any status
>> other than no carrier. I have tried everything including building a
>> custom kernel without the if_ix device and compiling the latest
>> version from Intel and installing that.
>> I have done an up command on the interfaces, tried setting an IP, but
>> nothing changes the status. Am I missing something or is the FreeBSD
>> Driver just not compatible with these Twinax Cables? The cards of
>> course were used with these cables on VMWare?
>> Here is the output from some commands below, there maybe some errors I
>> can't copy and past from the remote kvm console, so I had to type this
>> from reading the screen. this is just the first of the 4 interfaces.
>> dmesg:
>> ix0: <Intel(R) PRO/10GbE PCI-Express Network Driver, Version - 3.2.17>
>> Port 0xccc0-0ccdf mem
>> 0xdeb40000-0xdeb5ffff,0xdeb80000-0xdebbffff,0xdeb38000-0xdeb3fff irq
>> 47 at device 0.0 on pci11
>> ix0: Using MSI-X interrupts with 9 vectors
>> ix0: Ethernet address: 00:00:c9:85:33:22
>> ix0: PCI Express Bus: Speed 2.5GT/s Width x8
>> pciconf -lv:
>> ix0 at pci0:11:0:0:   class=0x020000 card=0xe41010df chip=0x10c68086
>> rev=0x01 hdr=0x00
>>   vendor   = 'Intel Corporation'
>>   device   = '82598EV 10-Gigabit AF Dual Port Network Connection'
>>   class    = 'network'
>>   subclass = 'ethernet'
>> ifconfig -v ix0
>> 9000
>>   ether 00:00:c9:85:33:22
>>   hwaddr 00:00:c9:85:33:22
>>   media: Ethernet autoselect
>>   status: no carrier
> I've never tried with twinax cables but remember going down a similar
> path with an Intel 82599ES card and the included multimode optics. In
> the end, the ix driver in GENERIC plus "hw.ix.unsupported_sfp=1" in
> /boot/loader.conf allowed both ports to link correctly.
> Not positive if that's it here but hope that helps.

Already have that option set, ran across it searching online.

    Dean E. Weimer

More information about the freebsd-questions mailing list