Problems Connecting Laptop To Modem

B J va6bmj at
Wed Jun 20 01:17:24 UTC 2018

On 6/19/18, Polytropon <freebsd at> wrote:


> Try to ping "step by step": first your router by IP, then
> a public IP address which definitely will answer (for
> example, and then something that involves name
> resolution (for example If name
> resolution is a problem, the ISP's DNS (or the DNS you
> are using) should be examined (dig / drill).

I'll try it and see what happens.

>> If it still does not work, set the network configuration to manual.
>> Check with the router what address range is reserved for manual usage.
>> If nothing is reserved, reserve a block of 16, 32 or what ever you like
>> addresses. Enter one of these addresses into your /etc/rc.conf and try
>> again.
> It's still not clear (to me) if the router/modem provides DHCP
> or not. If it doesn't, manual configuration is needed, but if
> it does provide DHCP, this should be used - and investigated
> if it doesn't work as expected.

It appears to as I've got a tower running FreeBSD connected to it.  I've got:


in /etc/rc.conf and I have no problem connecting to any of the
websites I regularly look at.

>> You also could try to run dhclient manually.
> I still suggest running tcpdump (or Wireshark) in parallel
> to see the corresponding traffic. If the machine (for unknown
> reasons) doesn't get the DHCP handshake right - it needs to
> perform the required network traffic and should also update
> certain files and interface settings - there is a reason for
> it. It would sound strange that a defective network card can
> cause this strange kind of behaviour, but it's still possible...

I haven't tried that yet.


I swapped the current HD with a spare that I had on hand and installed
FreeBSD 11, though only the command line interface.

For some reason, the network card couldn't be configured with that set
up and I couldn't do it for the wireless card, either.  (The
modem/router has both Ethernet and Wi-Fi.)

I checked out the Wi-Fi with an IBM ThinkPad that runs an old version
of openSUSE and I could easily switch between it and Ethernet without
any problems.  It certainly doesn't look like the modem/router is the

I've got a few other things I'd like to try to see if I can narrow
down what's happening.

As I mentioned earlier, if I can't use this laptop with this
modem/router, it's no great loss as I've got two tower machines
running FreeBSD here at home.  If I can't use it here at home, I might
be able to use it at the house I inherited, which is in another part
of the country.  The machine itself has seen better days as I don't
think the previous owners took great care of it, judging by how dirty
it was when they gave it to me.  (I think they got it from one of the
local cable TV companies as a gift for signing on with that service
and, so, it didn't cost them anything.)

Even if I can't use it with the router/modem, I may as well use it to
learn something about FreeBSD and networking.


More information about the freebsd-questions mailing list