Windows via bhyve at FreeBSD11.1

Andreas Drewke andreas at
Thu Jul 5 18:24:17 UTC 2018


I got it.

I had 2 problems.

- First I did not see anything as I was connecting with freerdp which 
does not work. Using vncviewer indeed does.
- But I need to press quickly a key after connecting with vncviewer in 
the window I started the bhyve or in the vnc viewer. Not 100% sure here.
(Also order of drives seem to be important, haveing cd first worked for 
me, having cd as second did not, this was a hint on

Now my windows does install.

I am super curios. Using "vncviewer" is worth a note in a blog or 
documentation I think. Spend like 8+ hours to find out how to boot a 
Windows 7/8.1,10 in bhyve under FBSD.

Many thanx.

Best regards

On 07/05/18 18:22, Andreas Drewke wrote:Hi,
> Hi,
> I am a fulltime FreeBSD user now for a few months and do mostly game 
> related software development next to emailing, web browsing and such...
> But now I need a build environment of my stuff for Windows and Linux. 
> As I do not have dedicated machines for that I would prefer VMs inside 
> FreeBSD for that to not to reboot each time I want to have a build.
> So I tried to do virtualisation of Windows 10 with bhyve at FreeBSD 11.1. 
> First I tried with VirtualBox but this was not a stable solution. The 
> VM would hang when compiling. Data have been lost and such.
> I followed those both tutorial
> - 
> -
> and came up with the following cmd to launch a Win 10 installation VM 
> session
> |bhyve \ |
> |-c 2 \ -s 0,hostbridge \ -s 3,ahci-hd,"/home/andreas/Virtual 
> Machines/BuildVM-Win10-x64.img" \ -s 
> 4,ahci-cd,"/home/andreas/Downloads/Win10_1803_German_x64.iso" \ -s 
> 10,virtio-net,tap0 \ -s 29,fbuf,tcp=,wait \ -s 
> 30,xhci,tablet \ -s 31,lpc \ -l com1,stdio \ -l 
> bootrom,/usr/local/share/uefi-firmware/BHYVE_UEFI.fd \ -m 2G -H -w \ 
> BuildVM-Win10-x64|
> I also tryed Win7, Win8.1. I also tryed to remaster Win7 DVD and such.
> But I always get:
> |Boot Failed. EFI DVD/CDROM Boot Failed. EFI Hard Drive|
> I also wonder why I need to run the command as root.
> "uname -a" tells
> |FreeBSD andreas-desktop 11.1-RELEASE-p10 FreeBSD 11.1-RELEASE-p10 #0: 
> Tue May 8 05:21:56 UTC 2018 
> root at amd64|
> "dmesg" tells:
> |CPU: AMD Ryzen 7 1700 Eight-Core Processor (2994.46-MHz K8-class CPU) 
> Origin="AuthenticAMD" Id=0x800f11 Family=0x17 Model=0x1 Stepping=1 
> AMD Features=0x2e500800<SYSCALL,NX,MMX+,FFXSR,Page1GB,RDTSCP,LM> AMD 
> Structured Extended 
> NP,NRIP,VClean,AFlush,DAssist,NAsids=32768 TSC: P-state invariant, 
> performance statistics|
> Any hints are highly appreciated.
> Many thanx and
> Best regards
> Andreas 

More information about the freebsd-questions mailing list