problem with upgrade and unable to build openjdk8 in poudriere

Johannes-Maria Kaltenbach johannes-maria at
Mon Jan 15 15:16:06 UTC 2018


I'm still working with 9.3 and thought it's time to install 11.1
but there are two problems I couldn't solve myself.

I've never worked with jails or poudriere before and probably
made some errors so I first describe in detail what I've done.

To not destroy my working system I made this on a separate
(clear) slice of my hard disk.

First I installed the basic 11.1 system with the boot disk
(FreeBSD-11.1-RELEASE-amd64-disc1.iso) without problems.

Then I installed poudriere (pkg install poudriere)
and created a jail with poudriere:
    poudriere jail -c -v 11.1-RELEASE -a amd64 -j 11amd64
and installed the ports tree:
    poudriere ports -c
I created a list of ports to install and started poudriere:
    poudriere -v bulk -j 11amd64 -f list_of_ports_to_install

First problem:

One of the ports to install is x11/kde4 which as a dependency
adds java/openjdk8 to the list but poudriere seems to be
unable to build it:
=>> Failed ports: java/openjdk8:build
[excerpt from the log-file:
gmake[2]: *** No rule to make target '1'.  Stop.
gmake[2]: Leaving directory '/wrkdirs/usr/ports/java/openjdk8/work/openjdk/langtools/make'

And therefore
=>> Skipped ports: devel/antlr devel/kdesdk4 devel/poxml x11/kde4

On the other hand a direct make in ports/java/openjdk8 is successful
but it fails repeatedly when called by poudriere.

Second problem:

I tried to install the successfully built software
(i. e. my list without kde4) with
    pkg -j 11amd64 upgrade
but this fails with
    pkg: jail "11amd64" not found

and jls doesn't list any jails
    poudriere jail -l
11amd64  11.1-RELEASE-p6 amd64 ftp    ... /usr/local/poudriere/jails/11amd64

Any help greatly appreciated.

Best regards,

More information about the freebsd-questions mailing list