certbot lost certificates , and registration data

Carmel NY carmel_ny at outlook.com
Tue Dec 11 10:57:19 UTC 2018

On Mon, 10 Dec 2018 23:14:23 +0000, Matthew Seaman stated:

>On 10/12/2018 20:46, Carmel NY wrote:
>> On Mon, 10 Dec 2018 17:56:22 +0000, Matthew Seaman stated:
>>> This was due to an upstream change moving where various paths are 
>>> defined to a different file, and so making the port's attempt to modify 
>>> the settings in the original file pretty futile.  I'll be working on a 
>>> fix later tonight.  
>> I am not sure if all of the py*-certbots are maintained by the same person;
>> but shouldn't they have caught this problem before releasing it? They must
>> have tested it, right?
>They're mostly maintained by python at FreeBSD.org which is a group of
>people (See towards the end of https://wiki.freebsd.org/Python).
>Yes, ideally this mistake would have been caught before the port was
>updated.  It's a slightly tricky thing though -- test building would
>have shown everything was fine.  It's only when anyone tried to *run*
>certbot that the problems become apparent, and no-one did that before
>committing the upgrade.  For routine updates patch-level updates like
>this one, 99% of the time just doing build tests is sufficient.  This
>unluckily happened to be one of the 1%.
>If anyone is interested in testing it, I've created a patch which can be
>downloaded from https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=233909
>	Cheers,
>	Matthew

I tried the patch, and it appears to be working. I'm using py36-certbot with
the apache option if that makes any difference.


More information about the freebsd-questions mailing list