xrdp configuration and xfce4

David Newman dnewman at networktest.com
Wed Aug 8 17:57:58 UTC 2018

On 8/8/18 9:32 AM, Oleg Cherkasov wrote:
> On 08. aug. 2018 04:10, David Newman wrote:
>> On 8/7/18 6:31 PM, Koichiro Iwao wrote:
>>> On Tue, Aug 07, 2018 at 06:24:15PM -0700, David Newman wrote:
>>>> Not sure what changes I would make in startxm.sh to automate this. The
>>>> existing script has file locations for X on Linux distros.
>>> Really?
>>> ```
>>> #!/bin/sh
>>> startxfce4
>>> ```
>>> That's all.
>> Sorry, no go.
>> A startwm.sh script with just these two lines produces a black screen
>> with one xterm and doesn't start xfce, let alone deal with the
>> copy/paste problem.
>> Also tried with '/usr/local/bin/xfce4-session' but got the same results.
>> Either of these is exactly the same outcome as using the default
>> startxm.sh script supplied with xrdp from the pkg repo.
>> I am restarting the xrdp service and exiting the xterm after each
>> attempt.
>> If you have this working successfully with a similar environment --
>> Microsoft RDP client on a Mac connecting to xrdp 0.9.x on FreeBSD 11.2
>> -- are you able to share your xrdp.ini and startwm.sh files?
> Have you tried to make ~/.xsession file with:
> #! /bin/sh
> startxfce4

Previously the .xsession file was just 'startxfce4'.

But adding the '#! /bin/sh' line and restarting xrdp did not change the
behavior: It's still a black screen with one xterm, and no xfce4 desktop
or copy/paste support.

Of course startxfce4 will run manually from the xterm but along with
copy/paste, those are the problems I'm looking to solve.



More information about the freebsd-questions mailing list