Restoring bootcode

Robert Fitzpatrick robert at
Sun Apr 29 16:38:19 UTC 2018

Something happens to the bootcode since an upgrade a while back and I've 
been starting this 10.4-RELEASE server at the loader OK prompt using 
'set currdev=disk0s1a' and then boot. Here is the server system...

root at dev:~ # gpart show
=>      63  41942977  ada0  MBR  (20G)
         63  41929587     1  freebsd  [active]  (20G)
   41929650     13390        - free -  (6.5M)

=>       0  41929587  ada0s1  BSD  (20G)
          0   1024000       1  freebsd-ufs  (500M)
    1024000    524288       2  freebsd-swap  (256M)
    1548288  20480000       4  freebsd-ufs  (9.8G)
   22028288  19901299       5  freebsd-ufs  (9.5G)

I've tried the following to install the boot code, but still ending up 
at the loader prompt...

root at dev:~ # gpart bootcode -b /boot/mbr ada0
bootcode written to ada0

I also tried with ada0s1 with same result. Clearly I don't understand 
how to get this done, can someone help?


More information about the freebsd-questions mailing list