upgrade of firefox from v54 to v59 hosed up

wa5qjh wa5qjh at xmission.com
Sun Apr 29 03:17:44 UTC 2018

First off  the system is:

FreeBSD fbsd11rd3 11.1-RELEASE-p9 FreeBSD 11.1-RELEASE-p9 #0: Tue Apr  3
16:59:16 UTC 2018    
root at amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC 
amd64     running UFS on partition 3 of 4 of a 1TB HD.
on an ASUS  intel i3 motherboard.

Two days ago  I upgraded Firefox from v54 to v59

In the process pkg also hosed up qt5, stripped many of my other apps
like telegram & quassel ( which is dependant on qt5), qtcreator, and
others  I havent tried yet. now Firefox will load many of the URL's that
it did before  but several  it wont.top among them being facebook and
the list of search engines in  the search bar:  Google, duck duck go,
bing, amazon etc.  In all of these cases the error I get now is:


Immediately after the update, firefox reported  that an SQLite lib had
not installed correctly, so I reinstalled that.

The update also updated Seamonkey and it reports  the same error.

Among sites not similarly rejected are TI.com piratebay ( which I tried
out of curiosity), amsat.org and several others. I cannot explain  this
nor why even after re-installing, quassel, and telegram-desktop appear
to be starting but soon die.

 This is not the first time such an update has wiped out other apps, it
happened while the system was 11.0 also, but that was months ago and,
fortunatly, I dont remember mucvh of the details.

I can see where this might appear as at least 2 independent problems,
but I dont believe it is.

Gary Corell
 Ya gotta think time beyond the end of your nose.

More information about the freebsd-questions mailing list