Disk not spinning up

Polytropon freebsd at edvax.de
Sun Sep 17 20:50:47 UTC 2017

On Sun, 17 Sep 2017 20:57:27 +0100, Matthew Seaman wrote:
> On 17/09/2017 20:43, Polytropon wrote:
> > This is more a hardware question than a FreeBSD question, but
> > as FreeBSD is involved, I think it's worth being asked here
> > due to the experienced, intelligent, creative and (in an
> > entirely positive sense) "unusual" participants on this list.
> > 
> > I have a harddisk Quantum Fireball with ca. 1 GB capacity
> > (yes, that's GB, not TB). It's a (P)ATA / "IDE" disk with
> > a 40 pin connector for a flat cable, configured as master.
> > 
> > The disk has been in use in a system that I built around 1995
> > and which I occasionaly used over the years. The last system
> > activation was yesterday. Today, the disk just didn't spin up
> > again.
> > 
> > After extracting the disk from the system and using my fine
> > "forensics adaptor" to power it, it made short cranking sounds
> > (ca. 1 per second) and short beeps from time to time, then went
> > silent. I can repeat this.
> > 
> > Now I probably did something stupid, but a radio amateur friend
> > had success with this approach on a 40 MB disk (yes, that's MB,
> > not GB). I _opened_ the disk (with gloves, face mask and cap,
> > just to minimize the dust falling from my head into the disk)
> > and saw the central motor "rotate" clockwise and counterclockwise
> > for less than 1/4 rotation. I tried to "help" the disk spin up
> > as you can imagine, but it would not do so.
> > 
> > My question:
> > 
> > Had anyone had success getting such a disk work again? Is it
> > worth searching my "museum" for a replacement controller? Or
> > does it look more like a motor failure than a controller failure?
> > 
> > I can read the disk with my "forensics adapter" like this (tested
> > with the other 1.2 GB disk from the same system):
> > 
> > 	$ sudo mount -t msdosfs -o ro /dev/da3s1 /mnt
> > 
> > That's the FreeBSD-related part in this question. But of course,
> > a disk not spinning up won't be recognized by the system. I'd like
> > to at least access the disk once to copy as much as I can.
> > 
> > Are there any ideas, options, chances, suggestions or experiments
> > other than "throw it out of the window"? :-)
> > 
> Considering the age of the disk, it's amazing it's still showing any
> signs of life at all.

Not at all. I'm a living museum and have plenty of "too old"
devices that work like a charm - until, of course, they suddenly
stop working ("But it worked yesterday!"). :-)

> What you are experiencing sounds like 'sticktion' -- over time the
> lubricants on the drive bearings slowly become more sticky, and this
> tends to have the effect that the drive won't start up from cold.

That sounds quite right. I had this problem in other kinds of
(primarily electromechanical) machinery where one of the two
possible things happened:

a) lubricant hardened (until total blocking or "glued state")

b) adjacent parts "melting" (usually rubber and soft plastics)

I can manually move the disk spindle, so the rotation is basically
possible. The upper part of it is connected to the top of the
enclosure, the motor itself, located at the bottom, cannot be

> This is one place where percussive maintenance is justified.  If you can
> tap the drive in just the right way as it is trying to spin up, you may
> be able to get it past the first few turns, after which it should be
> able to gather enough momentum to keep going.  You want to hold the
> drive flat on the table, and tap the corner of the drive so that it
> rotates in the same plane that the platters do.  You'll have to
> experiment to see what's most effective.

I will definitely try that, as I think I cannot make the problem
much worse. :-)

> Once you do get the platters moving, eventually the drive should come up
> to normal operating temperature and that  which should soften the
> lubrication enough for it to run normally for a while, if you're lucky.

Pre-heating (as suggested below) might be a way to help the drive.

> The drive is definitely in its death throws, and your only hope is to
> concentrate on recovering any data that you can in whatever short time
> is left to it.  If any.

Plus dust. :-)

I could also check if I have a "compatible" disk somewhere, but this
probably won't help, as it's not the controller (I think) that fails
to operate correctly. The only way here would be to put the platters
into a replacement drive (on its axis), and properly adjusting them
is something reserved to a real (!) clean room environment with far
more expensive testing and adjustment equipment than I have.

On Sun, 17 Sep 2017 16:29:06 -0400, Ernie Luzar wrote:
> The bearing the disk platters rotate on has lubricant that with usage 
> and time has dried out somewhat. Taping the top side of the drive on a 
> flat surface some times works.

I've already tried the "knock it with a little hammer" approach,
but this is really something that involves _lots_ of tries, as
it depends on the exact timing, direction, and force to help the
motor spin up.

> The best approach is to per-warn up the drive hardware before trying to 
> power it on. Put a bear light bulb or shine a flood light from a close 
> distance on to the metal covered side, IE; not the circuit board side, 
> until it gets almost to hot to touch. Then power it on and and away you 
> go almost every time this happens.

I will definitely add this as even more help.

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list