[SOLVED] Re: TCP connection stalled

Nagy László Zsolt gandalf at shopzeus.com
Wed Mar 8 07:16:24 UTC 2017

>  > The internet connection has download speed 500Mbps and upload speed 30Mbps.
> Lucky you :)  Is that via PPPoE or what protocol? (may matter re mtu)
It is a cable modem, not using PPPoE. But I'm not sure about the correct
>  > Internet is connected via a public IPv4 address as shown below (real ip
>  > hidden with 'x' chars)
>  > 
>  > nfe0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
>  >         ether 40:61:86:ed:e6:41
>  >         inet 37.xxx.xxx.xxx netmask 0xfffffe00 broadcast
> That seems a strange broadcast address with that IP and netmask?  Never 
> mind, perhaps that's different on FreeBSD 11?
I guess it was given by the DHCP server of the ISP, they hopefully have
a good reason for using a 9 bit wide subnet. :-)
> Likely due to ipfw(8) /BUGS, near the end (applies to natd too)
>      Due to the architecture of libalias(3), ipfw nat is not compatible with
>      the TCP segmentation offloading (TSO).  Thus, to reliably nat your net-
>      work traffic, please disable TSO on your NICs using ifconfig(8).
> See ifconfig(8).  You need ifconfig nfe0 -tso4 and possibly? -vlanhwtso, 
> with the same applying on your LAN-facing interface.

I don't say I fully understand this, but after executing this:

ifconfig nfe0 -tso4 -vlanhwtso

the upload speed went up to 1.8MB/sec instantly. :-)

Problem solved! Thank you!

More information about the freebsd-questions mailing list