TCP connection stalled

Fabian Keil freebsd-listen at
Fri Mar 3 17:28:39 UTC 2017

Nagy László Zsolt <gandalf at> wrote:

> Hello, I have this setup:
> Remote computer <---> Internet <----->  Gateway <---->  NAT-ed local
> network <---> Internal computer
> The gateway is a  11.0-RELEASE-p8 running natd + ipfw.
> If I try to copy something to a remote server with this command:
> scp local_file user at remote_computer:~
> Then the following happens: the first few 100K data goes through
> quickly, then the connection becomes stalled. I have tried different
> remote computers on different ports, but the result is always the same.
> I have also tried passive mode FTP instead of SCP with the same result:
> stalled.
> If I do the same from the internal computer behind NAT, then all uploads
> and downloads are fast and responsive. The connection is stalled only
> when I connect from the gateway (or to the gateway). (E.g. copy from
> internal computer -> remote computer is fast and reliable.)
> But there was no effect at all. SCP and FTP connections are both
> stalled. (I can send an example tcpdump if required, but I could find
> nothing special in that.)
> What else can cause this? What should I look for?

You may be affected by this regression:

You could check the "vmstat -z" output and try the patches.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the freebsd-questions mailing list