Linuxulator / Chrome

Mason Loring Bliss mason at
Sat Jun 3 04:04:16 UTC 2017

Hi all. Will Chrome work on Linuxulator if I chase down enough dependencies?
I'm trying to get BlueJeans running, and it's balking in both Firefox and
Chromium on FreeBSD (11-STABLE) so I figured I'd give Chrome under the
Linuxulator a try. I hit several missing libraries until I realized I needed
to install the whole linux-c6 (also tried linux-c7) suite.

Once that was done, I hit this:

    ./chrome: error while loading shared libraries: cannot
    open shared object file: No such file or directory

We don't seem to have a package for it.

I tried running ldd to see what other libraries I'd need, but the ldd in
/compat bailed out, saying "missing file". I suspect it's not intended to be
used, as it has /bin/bash in the shebang line. The native LDD was unhappy
with the Chrome binary.

I've now pulled out a list of libraries from a Linux machine where I could
run ldd, and I can collect the libraries by hand from Linux to populate
/compat, but I'm really interested in knowing if anyone's gotten Chrome
working this way, or if I'll run into known obstacles once I have all the
libraries in place.


Mason Loring Bliss             mason at            Ewige Blumenkraft!
(if awake 'sleep (aref #(sleep dream) (random 2))) -- Hamlet, Act III, Scene I
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <>

More information about the freebsd-questions mailing list