failed to set mtrr: Invalid argument

Polytropon freebsd at
Mon Jul 31 04:24:32 UTC 2017

On Sun, 30 Jul 2017 18:12:24 -0700, David Christensen wrote:
> I have installed lumina.  'start-lumina-desktop' causes the screen to 
> flicker and then return to the CLI:
> $ start-lumina-desktop
> No X11 session detected: Lumina will try to start one...

I think I had that kind of problem last year. The error message
did not really help, so I finally decided to start X with only
one X terminal open, and then ran "start-lumina-desktop" from
that "controlling shell". It didn't work (as in your case), and
I did then use "truss start-lumina-desktop", found out what was
wrong, but I cannot remember what it was, sorry. Lumina worked
for some time, even though it was partially incomplete. After
a "pkg upgrade" of the system, it didn't work anymore, and I
was not able to return it to a working state, so I dumped it
and installed fvwm2 which worked (and still does after several
software upgrades). :-)

Side note:

Have you tried creating a ~/.xinitrc and putting the command
"exec start-lumina-desktop" into that file, then use "startx"
from text mode? That is a common way to start X sessions (when
you're _not_ using a display manager like xdm).

> Note the error message "failed to set mtrr: Invalid argument".

That might have been the error message that I saw as well.

> How do I make Lumina work?

Good question. ;-)

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list