ZFS fails with error 6 on upgrade to 11.1

Goran Tepšić purpleritza at gmail.com
Fri Jul 28 22:18:40 UTC 2017

Couple of days ago I had issue with upgrading to 11.1 where I tried a bit
exotic way of upgrading by creating boot environment, mounting it and
running freebsd-update to send files to that boot environment's directory.
After I tried to boot, ZFS complained.

I tried couple of things to recover but I think 'zfs set cachefile
/boot/zfs/zpool.cachefile' actually saved my 🥓. Not entirely positive but
worth trying.

On Jul 28, 2017 11:37 PM, "Sebastian Schwarz" <seschwar at gmail.com> wrote:

On 2017-07-28, Goran Tepšić wrote:
> Hmm. Can you do 'zfs get bootfs,cachefile ssd'?


> # zpool get bootfs,cachefile ssd
> NAME  PROPERTY   VALUE                    SOURCE
> ssd   bootfs     ssd/ROOT/freebsd11.0.11  local
> ssd   cachefile  -                        default

That bootfs is my currently working dataset.  I selected the
dataset with 11.1 using the boot loader's menu.

I tried setting bootfs to `ssd/ROOT/freebsd11.1.0` to see if
that would make a difference, but it didn't.

More information about the freebsd-questions mailing list