Freebsd 11.0p11 - system freeze on intensive I/O

Gautam list at
Mon Jul 24 09:13:45 UTC 2017


I am not sure if this is the right list to post to, but thought to start
checking this issue here.

I came back to using FreeBSD after many years on my laptop. The machine is
currently in a dual-boot configuration and I basically replaced FreeBSD to
replace the earlier Ubuntu installation. Machine is at 11.0-RELEASE updated
to p11 via freebsd-update.

I encountered a similar outcome of total system freeze in two kinds of
usage. State of the system:
1) X is not usable - I use xfce - no login manager
2) I cannot ssh into the box - I do not get the username or password prompt
- connection just times out
3) the network interface is ping-able.
4) I am not able to switch to the system consoles using Ctrl-Alt-F1..8
5) No mouse movement nor screen update
6) I suspected an issue with soft-update and then turned that off.
Filesystem is ufs. fsck is clean.

Recovery: hard-boot, system comes up, fsck happens, some errors fixed and
resumes working normally.

The problem became visible in two kind of usage scenarios:
1) Running the backup port duplicity to create a backup of the /
filesystem. It would start but at some point but then get stuck. Running it
in verbose mode would sometimes indicate that this would happen when the
write to the volume (default setting of 200M) happens. This was tried 4-5
2) running split on a 6.4G file (filesystem dump of disk using dump) --
something like
split -d -b 200M -a 4 - part
This would then freeze at one point - making the system unusable. I tried
this 2-3 times.

I finally got it to work using idprio 31 before the split command. Tried
this only once - havent tried it with the duplicity command.

I do not suspect the hardware since I have been running ubuntu without
similar issues but am open if any tests need to be run. The machine has 8GB
RAM and is clearly not reaching the out of memory kind of situation -
basically only about 1.1 or so GB is used.

I also ran this from the system console without X and faced the same issue
- no panic message - nothing in the logs as well.

The next steps for me:
A) Try to reproduce this on a virtual machine - since I cannot keep toying
around with the laptop disk and risk losing days of work.
B) Try to capture needed information to help debug this further. Not sure
what all is needed here.

Any comments on how I can proceed with solving this ? I would really like
to solve these issues and am actually quite surprised at getting stuck at
this - this being a single user simple kind of usage scenario.


More information about the freebsd-questions mailing list