How to fix wx error ?

Manish Jain bourne.identity at
Thu Jul 6 15:01:50 UTC 2017

On Thu, Jul 6, 2017 at 11:40 AM, Jack L. <xxjack12xx at> wrote:
There is a pending patch that fixes this. Issue is wxgtk was compiled with clang and audacity was compiled with a newer gcc causing the issue. This patch should make audacity compile with clang On Wed, Jul 5, 2017 at 3:13 PM, Manish Jain <bourne.identity at<mailto:bourne.identity at>> wrote:
Hi, I am running FreeBSD 10.3 amd64. I had an internet outage for about 20 days, and got network connectivity again yesterday. When I started the system again yesterday, pkg conked out with the complaint that it was not able to find packages for release 10 under quarterly. 'pkg update -f' did not help; so I reinstalled the system : - ) The reinstall has consumed me the last 24 hours, but I am pretty much done. Except for one error - audacity refuses to start with this message : Fatal Error: Mismatch between the program and library build versions detected. The library used 3.0 (wchar_t,compiler with C++ ABI 1002,wx containers,compatible with 2.6,compatible with 2.8), and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.6,compatible with 2.8). Google search suggests this error has something to do with wx widgets libraries. So I deleted all wx packages and audacity, and built audacity from /usr/ports. That however does not help. I continue to get the same error.

Hi Jack,

Thanks for letting me that there is a possible solution.

I applied the patch. Running make under /usr/ports/audio/audacity now gets me the following error :

checking whether we are using gcc 4.9.0 or later... no
configure: error: Audacity requires at least GCC 4.9
===>  Script "configure" failed unexpectedly.

This is surprising because gcc5 as well as gcc6 are insalled on this box (gcc5 from pkg, gcc6 from ports).

Is there something I need to tweak further ? Thanks
Manish Jain

More information about the freebsd-questions mailing list