freebsd-update fetch

Matthew Seaman matthew at
Sat Jan 21 22:27:58 UTC 2017

On 21/01/2017 21:51, Stari Karp wrote:
> My system is FreeBSD 11.0_RELEASE-p7 (amd64).
> I have today (the third time in 3 weeks) when I run freebsd-update
> fetch:
> The following files will be updated as part of updating to FreeBSD
> 11.0-RELEASE-p7:
> /usr/share/man/mandoc.db
> /usr/share/openssl/man/mandoc.db
> Is this security update or something is wrong on my system? Usually is
> some email about update.

No -- this is a bug in freebsd-update(8).  The mandoc.db files are
supplied as part of the base system install, but it seems freebsd-update
is not managing to update them correctly.  This is pretty harmless
though -- the mandoc.db files are used by apropos(1) to show a summary
of the man pages in those sections.  All it means is that the database
of manpages may be slightly out of date.

I think you may be able to simply move aside the existing mandoc.db
files, and then run 'freebsd-update fetch install' to replace them with
pristine copies of the latest versions.  I haven't tried that though.



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 931 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the freebsd-questions mailing list