Second attempt at FreeBSD-11.0-RELEASE-i386, Xorg, and Xfce graphical desktop

Markus Hoenicka markus.hoenicka at
Thu Jan 19 22:15:20 UTC 2017

At 2017-01-19 15:53, Warren Block was heard to say:
> On Thu, 19 Jan 2017, Markus Hoenicka wrote:
>> At 2017-01-19 06:15, Warren Block was heard to say:
>>> On Wed, 18 Jan 2017, Sergei Akhmatdinov wrote:
>>>> Not sure why XFCE needs so much work over what is essentially a 
>>>> `shutdown
>>>> (-r|-p) now` wrapper.
>>> I just add those entries to the polkit file and it works.  If there 
>>> is
>>> something else that needs to be done, I did it a long time ago, but
>>> I'm pretty sure I have set up machines from scratch with the same
>>> configuration.
>>> _______________________________________________
>> I just reinstalled a laptop with 11-RELEASE and ran into the very same 
>> problem that you seem to *not* have. I have enabled just about 
>> everything (polkitd|hald|dbus|whatnot) in rc.conf, I've granted my 
>> user account the rights to do everything in the polkit config file, 
>> and still cannot shut down or restart the box using XFCE's logout 
>> dialog. sudo /sbin/poweroff runs flawlessly though, so it is not 
>> really an issue. It is just a wart on an otherwise smooth setup. I 
>> have not tried to build XFCE from the ports tree though. Will try as 
>> soon as I get round to it.
> That's an interesting idea.  Maybe the hal requirement when using
> packages interferes with the shutdown.
> It would be nice to solve this, then we can add it to the pkg-message.

Turns out to be a case of not RTFM. I do not use a display manager. 
Instead, I run startxfce4 from the console after logging in. The XFCE 
docs say to use startxfce4 --with-ck-launch in this case:

Things may work out of the box if you use a display manager.


Markus Hoenicka
AQ score 38

More information about the freebsd-questions mailing list