pf can't get memory for tables

Scott Bennett bennett at
Thu Feb 16 06:12:56 UTC 2017

     I have a rather long list of IP addresses and address ranges in a file
loaded by pf for reference by a block rule.  After the latest addition of a
batch of addresses to be blocked, I got an error when I tried to reload the
file into the table in pf.

hellas# pfctl -f /ztmp3c/pf/pfbnew -t Crackers -T replace
pfctl: Cannot allocate memory.

What value can I increase to accommodate pf, so that it can reload the table?
(Stopping and restarting pf also fails with the same error message.)  I expect
to continue adding more addresses into the foreseeable future, so I have to
be able to continue to satisfy pf's needs.
     Please include me directly in any response because I'm subscribed to the
digest form of this list.
     Thanks in advance for any help!

                                  Scott Bennett, Comm. ASMELG, CFIAG
* Internet:   bennett at   *xor*   bennett at  *
* "A well regulated and disciplined militia, is at all times a good  *
* objection to the introduction of that bane of all free governments *
* -- a standing army."                                               *
*    -- Gov. John Hancock, New York Journal, 28 January 1790         *

More information about the freebsd-questions mailing list