zfs upgrade "gpart: /dev/da4p1: not enough space"

Russell L. Carter rcarter at pinyon.org
Mon Feb 6 23:29:13 UTC 2017

On 02/04/17 20:55, Russell L. Carter wrote:
> Greetings,
> amd64 11/stable
> So I'm on the last machine of a zpool upgrade everybody, and on the
> very last, and most important pool, I zpool upgraded and then
> went to finish the boot zpool and what did I see:
> root at terpsichore> gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1
> da3
> gpart: /dev/da3p1: not enough space
> So... what do I do now?  It's happy staying up for days, but... will
> I have to reinstall the system to make da3p1 big enough?

Ok, I sent that over the weekend.  I think this is important enough
that the proper response to encountering this situation should be made
visible to google at least.  I have tried various searches and found
zero results so far.

To recap, in part because of the annoying text that shows up with
every zpool status, I upgraded all of my zfs pools.  On the first four
bootable pools, I successfully followed the instructions to update the
bootcode as described above, adjusted for the appropriate device.  On
updating the final boot pool, I get the error:

gpart: /dev/da3p1: not enough space.

The filesystems in that pool are not near full, btw.  The pool itself
was created from a 10.0 system and is a mirror, and updating the
bootcode for other drive returned the same error, unsurprisingly.

So, 1st question that it would be helpful to get a google answer for
in the future:  is this pool now unbootable?

2nd question, if it is not bootable, is there a way to rescue it?

Otherwise, I am guessing, I will have to completely reinstall (including
repartitioning, etc.) the system, in order to regain a bootable system.

Maybe that should be part of the instructions that obeying the
incessant nagging from the zpool status command can lead to this kind
of unexpected and time consuming... exercise.


More information about the freebsd-questions mailing list