ZFS and replaced motherboard

Grzegorz Junka list1 at gjunka.com
Fri Dec 29 14:10:56 UTC 2017

On 23/10/2017 04:52, Shane Ambler wrote:
> On 22/10/2017 23:13, Grzegorz Junka wrote:
>> I have replaced a motherboard with almost an identical (the new one only
>> doesn't have a LSI SAS2 controller, which wasn't used anyway).
>> So, I was surprised to see that ZFS automatically recognized the pool
>> after I booted up the system on the new motherboard despite the fact
>> that accidentally some SATA ports have been swapped (i.e. disks weren't
>> connect to the same SATA ports as on the old motherboard).
> ZFS is recognised by info stored on the disk. The same pool should be
> able to be imported on different hardware and systems
> - like Illlumos or Solaris/sparc64
>> However, there is one thing that differs from the old system and that's
>> how those disks are reported:
>>   diskid/DISK-WD-WCC1U3689037p3  ONLINE  0  0  0
>> Ignore the checksum error, that's because one disk wasn't connected
>> properly for a couple of minutes but then was reconciled. The issue is
>> that these disks no longer show as ada1, ada2, ada3, ada4, ada5, ada6. Why?
>> The same with the M.2 nvm-e disks:
>> diskid/DISK-S1XXNYAH300115  ONLINE  0  0  0
>> They should be showing as nvd0 and nvd1. How to correct this? Does this
>> need to be corrected?
> It doesn't have to be corrected, but it can be easier for us to read.
> Try adding
> kern.geom.label.disk_ident.enable=0
> to /boot/loader.conf

Hi Shane,
Thank you for the tip. I just tried it by setting in the command line (I 
didn't want to restart the server). It worked with NVMe disks but not 
with SATA disks:

root at server:~ # sysctl -a | grep disk_ident
kern.geom.label.disk_ident.enable: 0

root at server:~ # zpool status
   pool: tank1
  state: ONLINE
   scan: resilvered 780K in 0h0m with 0 errors on Sun Sep 10 08:44:03 2017

         NAME                               STATE     READ WRITE CKSUM
         tank1                              ONLINE       0     0 0
           raidz2-0                         ONLINE       0     0 0
             diskid/DISK-WD-WCC1U3689037p3  ONLINE       0     0 0
             diskid/DISK-WD-WCC1U3680535p3  ONLINE       0     0 0
             diskid/DISK-WD-WCC1U4178255p3  ONLINE       0     0 0
             diskid/DISK-WD-WCC1U4176715p3  ONLINE       0     0 0
             diskid/DISK-WD-WCC1U3531030p3  ONLINE       0     0 0
             diskid/DISK-WD-WCC1U3565183p3  ONLINE       0     0 0

errors: No known data errors

   pool: tank5
  state: ONLINE
   scan: none requested

         NAME        STATE     READ WRITE CKSUM
         tank5       ONLINE       0     0     0
           mirror-0  ONLINE       0     0     0
             nvd1    ONLINE       0     0     0
             nvd0    ONLINE       0     0     0

errors: No known data errors

Why only NVMe? Would adding to bootloader.conf change anything?


More information about the freebsd-questions mailing list