Efi/mbr freebsd-11.0-RELEASE-p9 unbootable

Antonio Olivares olivares14031 at gmail.com
Tue Apr 18 17:17:31 UTC 2017

On Thu, Apr 13, 2017 at 11:45 PM, Heikki Lindholm
<holindho at saunalahti.fi> wrote:
> On 14.04.2017 05:38, Antonio Olivares wrote:
>> Dear freebsd users,
>> I got a used toshiba-laptop with windows 7.  A friend of mine gave me a
>> new
>> hard drive and we installed void-linux with a 1GB /boot partition, an 8 GB
>> swap partitionx and a 100GB / for the install.  Installation suceeded, but
>> grub install failed some ttx? Error.  I then got a regular x86_64 amd
>> freebsd 11.0 RELEASE and installed it sucessfully as well.  I did not get
>> questioned to install bootloader. When booting the machine tries to boot
>> off the network.  I get a supergrubdisk and boot off it and I am able to
>> run freebsd-update on it get it to -p9 and install pkgs that I want to
>> run.  I am not very fond of secure boot and I had installed linux on
>> another machine with windows 7 and it supposedly had EFI support, however
>> when grub installed, i lost the ability to boot into windows.  In this
>> machine a toshiba satellite laptop, I tried to play it safe and instead
>> cannot boot either void-linux or freebsd from the hard drive.  I can boot
>> into freebsd with supergrubdisk, i don't believe it is a question of EFI
>> because I had previously installed DragonflyBSD 4.8 which has support for
>> EFI and I selected it as well, but the system was unbootable as well.  How
>> should I troubleshoot this?  I can boot from live media, but I cannot
>> install grub or the freebsd bootloader.  Hard drive is 465 GB, with the
>> above mentioned linux partitions, the rest for freebsd with ufs.  If there
>> is a how to, or a laptop wiki on this topic, I appreciate all your help
>> even if it would be recommended that I reinstall the OS again from
>> scratch.  I am confused with GPT vs old style MBR which just worked TM by
>> the way and this secure boot crap which renders our machines unbootable.
> Show the output of gpart show ada0 (or whatever your disk is) for better
> guesswork to begin. You might need to (1) disable secure boot, (2) enable
> bios emulation, (3) install FreeBSD (and linux) with the BIOS/MBR booter
> instead of EFI.
> Regards,
> Heikki Lindholm
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

Before taking out a hammer and nuking everything, I will show what
output of gpart:

root at toshiba-f104:~ # gpart show ada0
=>       34  976773101  ada0  GPT  (466G)
         34       2014        - free -  (1.0M)
       2048    2097152     1  linux-data  (1.0G)
    2099200   16777216     2  linux-swap  (8.0G)
   18876416  209715200     3  linux-data  (100G)
  228591616       1024     4  freebsd-boot  (512K)
  228592640  740293624     5  freebsd-ufs  (353G)
  968886264    7886870     6  freebsd-swap  (3.8G)
  976773134          1        - free -  (512B)

root at toshiba-f104:~ #

I use SUPER GRUB DISK to boot.  I check the linux-data and it should
be linux /boot which is ext2 partition, just that grub failed to
install.  If I try stuff out and it does not work, then I will just
give it back to my friend.   I check the bios, I cannot find the
secure boot option to disable it :(  Any pointers and suggestions
before I take out the hammer or give up and give it back to my friend.

Laptop is a SATELLITE L775-S7135 which should be supported.

Best Regards,


More information about the freebsd-questions mailing list