Efi/mbr freebsd-11.0-RELEASE-p9 unbootable

Antonio Olivares olivares14031 at gmail.com
Fri Apr 14 02:38:17 UTC 2017

Dear freebsd users,

I got a used toshiba-laptop with windows 7.  A friend of mine gave me a new
hard drive and we installed void-linux with a 1GB /boot partition, an 8 GB
swap partitionx and a 100GB / for the install.  Installation suceeded, but
grub install failed some ttx? Error.  I then got a regular x86_64 amd
freebsd 11.0 RELEASE and installed it sucessfully as well.  I did not get
questioned to install bootloader. When booting the machine tries to boot
off the network.  I get a supergrubdisk and boot off it and I am able to
run freebsd-update on it get it to -p9 and install pkgs that I want to
run.  I am not very fond of secure boot and I had installed linux on
another machine with windows 7 and it supposedly had EFI support, however
when grub installed, i lost the ability to boot into windows.  In this
machine a toshiba satellite laptop, I tried to play it safe and instead
cannot boot either void-linux or freebsd from the hard drive.  I can boot
into freebsd with supergrubdisk, i don't believe it is a question of EFI
because I had previously installed DragonflyBSD 4.8 which has support for
EFI and I selected it as well, but the system was unbootable as well.  How
should I troubleshoot this?  I can boot from live media, but I cannot
install grub or the freebsd bootloader.  Hard drive is 465 GB, with the
above mentioned linux partitions, the rest for freebsd with ufs.  If there
is a how to, or a laptop wiki on this topic, I appreciate all your help
even if it would be recommended that I reinstall the OS again from
scratch.  I am confused with GPT vs old style MBR which just worked TM by
the way and this secure boot crap which renders our machines unbootable.

Best Regards,


More information about the freebsd-questions mailing list