Unable to add self to group vboxusers

Manish Jain bourne.identity at hotmail.com
Sun Apr 9 18:04:37 UTC 2017


Hi,


I am trying to run VirtualBVox under my under my system, a FreeBSD (p1) 
11 amd64 box with a radeon R5 230 (Caicos) card.


I did the following and rebooted :

a) installed virtualbox-ose via pkg

b) inserted vboxnet_enable="YES" in /etc/rc.conf

c) added self to users vboxusers with : 'pw groupmod vboxusers -m <X>'

d) added the following line to /etc/devfs.rules :

add path 'usb/*' mode 0660 group operator

Upon reboot, trying to run VirtualBox gets me :

libGL error: MESA-LOADER: failed to retrieve device information
libGL error: image driver extension not found
libGL error: failed to load driver: radeon
libGL error: failed to open drm device: Permission denied
libGL error: failed to load driver: r600
<html><b>Effective UID is not root (euid=1001 egid=1001 uid=1001 
gid=1001) (rc=-10)</b><br/><br/>Please try reinstalling 
VirtualBox.<br><br><!--EOM-->where: SUPR3HardenedMain
what:  2
VERR_PERMISSION_DENIED (-10) - Permission denied.
</html>
^C


When I run the groups command, I get different results based on 
effective UID :


a) as root, when I run 'groups <X>', I spot  vboxusers among the groups 
for <X>

b) as normal user, when I run groups I do not see vboxusers among my 
groups.


I am therefore unable to run VirtualBox. What exactly could be the 
problem that leads me into vboxusers not being among my groups ?


Thanks for any help

Manish Jain




More information about the freebsd-questions mailing list