'pkg install' complains txz not found

Matthew Seaman matthew at FreeBSD.org
Sat Apr 8 18:43:40 UTC 2017

On 08/04/2017 14:24, Manish Jain wrote:
> Hi,
> I am running FreeBSD 11 p1 on my tertiary (amd64) system. On this box, 'pkg search _xyz_' works normally, but 'pkg install _xyz_' always returns with the error :
> pkg: http://pkg.FreeBSD.org/FreeBSD:11:amd64/quarterly/All/_xyz_<version>.txz: Not Found
> I tried chromium and en_GB-libreoffice for _xyz_. When pkg retrned the error for chromium, I built www/chromium from ports successfully (in about 12 hours). I thought this was a one-off problem for chromium, but I now get the error for en_GB-libreoffice too. So obviously there is problem with pkg on this box. I already tried 'pkg update', which returns normally.
> Can anyone give me a clue as to how to fix pkg on this box ?

Is this using the default pkg configuration?

Try 'pkg update -f' to make sure that your local copy of the package
catalogue is in synch with what is on the repos.



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 931 bytes
Desc: OpenPGP digital signature
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20170408/15a92569/attachment.sig>

More information about the freebsd-questions mailing list