problems with make installworld DESTDIR=<newdirectory>

Jeff Anton antonfb at
Sun Oct 30 23:25:15 UTC 2016

I've been following the handbook "Updating Multiple Jails" section and 
the latest time I've tried that it has failed against 10.3-RELEASE-p11

I tried a couple different machines, each failed.

First, /usr/src/bin/freebsd-version install fails.

To fix that in its Makefile I change
SCRIPTS = freebsd-version

Then the install of /usr/bin/include fails with "env: not found"
I change
         env ECHO="${ECHO}" \
         /usr/bin/env ECHO="${ECHO}" \

Then the install fails with
mktemp not found
and in
I change
tmpfile=$(mktemp osreldate.XXXXXXXX)
tmpfile=$(/usr/bin/mktemp osreldate.XXXXXXXX)

It seems like these issues should have failed much earlier.  But maybe 
the DESTDIR stuff no longer works against an empty directory.  Seems 
like $path must be set to get stuff from the world being installed, but 
these installations depend upon stuff not yet installed.

I would also recommend that the handbook change the make installworld to

make -DNO_FSCHG installworld DESTDIR=${nr}

or recommend -DNO_FSCHG because my host machine is running in a secure 
mode which makes removing these old jails impossible until a reboot.

Anyone else seeing problems with make installworld DESTDIR=<new> ?

Jeff Anton

More information about the freebsd-questions mailing list