VirtualBox on a remote server (SOLVED)

Mario Lobo lobo at
Wed Nov 9 13:02:33 UTC 2016

On Wed, 9 Nov 2016 11:19:48 +0100
"Martin \"eto\" Misuth" <eto.freebsd at > wrote:

> On Tue, 8 Nov 2016 15:31:00 -0300
> Mario Lobo <lobo at> wrote:
> > Hi;
> > 
> > I have virtualbox running for a long time without any problems. The
> > version I had running on two servers was 5.0.14, and decided to
> > upgrade it to 5.1.8 with qt5. I tried compiling it with qt4 but the
> > compilation stops with an error.
> > 
> > Both servers have 10.3 stable r308305.
> > 
> > I did the upgrade on the first server and it went OK. I ssh to it,
> > type VirtualBox and the QT interface shows up fine on my local
> > display.  
> First I would check whether, first, working, server is not equipped
> with intel vga by any chance, making it work with libGL, while second
> one, being matrox equipped, fails.
> > process 11828: D-Bus library appears to be incorrectly set up;
> > failed to read machine uuid: Failed to open "/etc/machine-id": No
> > such file or directory
> > See the manual page for dbus-uuidgen to correct this issue.
> >   D-Bus not compiled with backtrace support so unable to print a
> > backtrace Abort trap (core dumped)  
> This error looks much weirder, and obviously is related to some DBus 
> silliness. Maybe you have DBus daemon failing (or not starting) 
> on that machine?
> In my opinion it boils down to way in which you are running
> virtualbox.
> It is some time I used virtualbox with FreeBSD, but I remember
> getting it run "properly" (as in-what I considered being proper)
> needed some dedication.
> Running vbox vm thorugh remoted X is certainly not proper, IMHO.
> If you are interested in trying the more "proper" (and more involved)
> setup, I can provide you with pointers, how it was done, but whether
> those would still apply I don't know.
> In the hindsight, whole thing was very, very subotimal and took some
> scripting to get semi reliable. I was using vbox + FreeBSD because of
> ZFS. ZFS was not that speedy when used this way, though, and vbox is
> not very "headless" friendly out of the box, either. Each vbox update
> meant recompile and so forth.
> I don't want to sound pessimistic, but I would not use such stack
> these days.
> So what is your reason to run vbox on FreeBSD specifically? 
> If it is ZFS as backing store, and you are not using "advanced" vbox
> features (USB redir, GL accel), it might be worthy of your time to
> explore whether your guests can run in bhyve, or try linux + qemu/kvm
> + ZFS. 
> In my experience either is much more sysadmin friendly, once you
> learn their warts, than vbox.
>   eto
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe at"

Hi Martin;

Thanks for replying.

Solved both errors!

The dbus error was solved by running:

dbus-uuidgen --ensure

To generate a machine-id, which was lacking.

The libGL error was solved by issuing:


The reason for this is because on X-forwarded ssh sessions, the
Xserver tries to open the display of the client, which in this case is
running on an Intel i915 card.

It was trying to use direct rendering and it can't for
whatever reason.

Setting the above env var solves the problem and I now get the
QT GUI on my display.

Mario Lobo
FreeBSD since 2.2.8 [not Pro-Audio.... YET!!]
"UNIX was not designed to stop you from doing stupid things, 
because that would also stop you from doing clever things."

More information about the freebsd-questions mailing list