VirtualBox on a remote server

Mario Lobo lobo at
Tue Nov 8 18:31:02 UTC 2016


I have virtualbox running for a long time without any problems. The version
I had running on two servers was 5.0.14, and decided to upgrade it to 5.1.8
with qt5. I tried compiling it with qt4 but the compilation stops with an

Both servers have 10.3 stable r308305.

I did the upgrade on the first server and it went OK. I ssh to it, type
VirtualBox and the QT interface shows up fine on my local display.

On the second server however, what used to work like the above with 5.0.14
(qt4), I now get this with 5.1.8:

[~]>LIBGL_DEBUG=verbose VirtualBox

libGL error: failed to open drm device: No such file or directory
libGL error: failed to load driver: i965
libGL: OpenDriver: trying /usr/local/lib/dri/
libGL: Can't open configuration file /root/.drirc: No such file or
libGL: Can't open configuration file /root/.drirc: No such file or
process 11828: D-Bus library appears to be incorrectly set up; failed to
read machine uuid: Failed to open "/etc/machine-id": No such file or
See the manual page for dbus-uuidgen to correct this issue.
  D-Bus not compiled with backtrace support so unable to print a backtrace
Abort trap (core dumped)

I don't understand why libGL keeps looking for i915 driver.

QT5 installed with no errors. I recompiled it and reinstalled it. Did the
same with libGL. Installed the mga x11 driver. (I didn't need that with the
previous VBox), kldloaded mga.ko

vgapci0 at pci0:6:0:0:     class=0x030000 card=0x04fa1028 chip=0x0534102b
rev=0x00 hdr=0x00
    vendor     = 'Matrox Electronics Systems Ltd.'
    device     = 'G200eR2'
    class      = display
    subclass   = VGA

None of that worked.

Any hints on what else I should try?


Mario Lobo
FreeBSD since version 2.2.8 [not Pro-Audio.... YET!!] (99,7% winfoes FREE)

More information about the freebsd-questions mailing list