X problem after upgrade 10.3 to 11.0 Release

Frank Shute frank at woodcruft.co.uk
Sun Nov 6 13:04:52 UTC 2016

On Sat, Nov 05, 2016 at 01:54:45PM +0100, Kenneth Hatteland wrote:
> I have tried both upgrade and fresh install of 11.0 Release, but every 
> time I reboot, and i starts up xorg and Gnome/KDE going, the screen 
> turns black with a no signal, going to sleep message. I reinstalled 
> again 10.3, which works like a charm, and then upgrade to 11.0 again 
> with the same problem. I have tried setting kern.vty=vt and also to "sc" 
> with no luck. So I guess there is something with 11.0 that does not work 
> on my Dell Optiplex 960 or that there is some tweak I have not found. 
> Does anyone have a tip that would point me in the right direction ? 
> Google and the release anouncement have not helped me so far.
> Blessed be,,
> Kenneth Hatteland

You make no mention of having updated your application software (aka

When you go from one major version to the next (ie. 10.* to 11.*) then you
should use ports that have been rebuilt using 11. It's not necessary when the
minor version is incremented ie. 10.2 to 10.3

You might be able to get away with installing the port: misc/compat10x, which
should allow softs built on 10.* to run on 11.*

For something complicated like X, I'd definitely want to rebuild with my new
base system.

After an incremented major version, I'd update my ports tree, install
misc/compat??x and rebuild all my ports using portupgrade.

Nowadays, I use poudriere and pkg upgrade.

With regards your X problem, you should be able to get a definitive reason for
it crapping itself by grovelling through /var/log/Xorg.0.log





More information about the freebsd-questions mailing list