how to downgrade X server

Will Parsons varro at nodomain.invalid
Tue Mar 29 20:53:51 UTC 2016

Warren Block wrote:
> On Tue, 29 Mar 2016, Will Parsons wrote:
>> Warren Block wrote:
>>> On Mon, 28 Mar 2016, Will Parsons wrote:
>>>> I haven't been using one.  The Xorg log shows:
>>>> ...
>>> The fbdev errors are ignorable.  Is that the entire log?  The Intel
>>> HD3000 should work fine.
>> No - I just started with the first errror messages.  I've included the
>> entire log below.
>>> As a start, please describe your hardware.  Some notebooks have hybrid
>>> graphics like Optimus which are a problem.  If that is not present,
>>> defining just the device in xorg.conf.d might be all that is needed.
>> It's a Lenovo Edge E520 laptop - see below for info from dmesg.
>> Any help is much appreciated.
> Specs from the web don't indicate any hybrid graphics, which is good 
> news.  The log file does not have any obvious problems.
> Please make sure there are no old xorg.conf files in /etc/X11/ or 
> /usr/local/etc/X11/.  Nothing more should be required, but it would do 
> no harm to manually set a Device as shown here:

I double-checked, but there wasn't.  I created the file
as per the handbook, but without success.

One other thing I tried (I don't know why this didn't occur to me
before) was to disconnect the external monitor I usually use.  But
again, I just got a black screen, this time on the built-in display.

> Probably also a good idea to use vt(4) in case the black screen is due 
> to X exiting.  In /boot/loader.conf, add
>    kern.vty=vt

I had already added that, but is there any way of verifying it has
taken effect?  The line "Using syscons driver with X support (version
2.0)" looks suspicious to me.

> That only takes effect after a reboot.
> Finally, check the contents of .xinitrc and .xsession for unexpected 
> things.  Neither is required.

There is no .xsession and the .xinitrc I've been using is pretty

if [ -f $HOME/.Xmodmap ]
   xmodmap $HOME/.Xmodmap

if [ -f $HOME/.Xresources ]
   xrdb -merge $HOME/.Xresources

if [ -f $HOME/.xbindkeysrc ]

exec wmaker

I tried temporarily renaming it, but no change to symptoms.

> Test X with just startx.  Don't try to use display managers like xdm or 
> gdm yet.

I do that anyway.


More information about the freebsd-questions mailing list