Intel 750 Panic Unmounting During TRIM

Peter Holm peter at
Tue Mar 22 20:25:31 UTC 2016

On Tue, Mar 22, 2016 at 12:59:35PM -0400, Nick Evans wrote:
> I've got a test system with a 400GB Intel 750 NVME SSD formatted UFS
> 1mb/4k aligned
> I moved a 50 gigabyte directory off the drive so I could try another
> drive configuration and while the drive was trimming, I ran umount on
> the mounted device. umount sat there without returning to the prompt. On
> another terminal, mount showed the drive unmounted, but after a minute
> or so in this state with gstat running to show io, the system panicked.
> I tried to reproduce this a second time by generating a 100gb file from
> /dev/zero. Deleted the file ran umount which hung again. This time
> after a while it returned to the prompt stating the device was
> busy so I tried to umount again while the drive was still trimming.
> After a short while the system panicked. It seems the panic happens
> when the TRIM finishes while umount is trying to do its thing. The
> system is 10.2-RELEASE-p13, GENERIC kernel, Intel 4790K on a Asus Z97-A
> motherboard, 32GB ram. I have a second Intel 750 drive in another PCI
> Express slot but it's unused at the moment. 
> Below are the dumps recorded after the system booted back up. This is a
> test system so I can bring it up and down as needed to test fixes. The
> second dump is from my reproduced test:
> panic: losing buffer 1
> cpuid = 2

I see a different panic with this scenario:
panic: Lock Per-Filesystem Softdep Lock not exclusively locked @ ../../../ufs/ffs/ffs_softdep.c:1950

- Peter

More information about the freebsd-questions mailing list