Write-Command timeout on MacBook Air 2013/SSD

Marcel Kessler marcel.kessler at posteo.de
Sat Jul 23 13:16:11 UTC 2016

I am trying to install FreeBSD on my MacBook Air 2013 with an installed
SSD. Sadly i get some write Errors, seems like the SSD doesn't respond
some times.

The exact error is: 
(ada0:ahcich0:0:0:0:0): WRITE_FPDMA_QUEUED. ACB: 61 ...
(ada0:ahcich0:0:0:0:0): CAM status: Command timeout
(ada0:ahcich0:0:0:0:0): Retrying command

The installation process will continue, but is pretty slow. The error
occours randomly. But often while extracting the ports.txz. When i
minify the data which needs to be extracted via  excluding ports.txz,
doc.txz, lib32.txz, ... and i have some luck, i can install FreeBSD
without an error. But the error still occours while using the installed

The SSD is fine. Works with MacOS, Debian, Arch, OpenBSD, ... I tried
diffrent Flash-Drives and even two SD-Cards via the CardReader. I also
tried the netinstall.  I tried
every option in the UFS-settings (TRIM, v1, ...). I am trying to install
FreeBSD side-by-side with MacOS (like i always did with linux Distros).
I have enough free diskspace.

Hope you can help me. Thanks!


More information about the freebsd-questions mailing list