Problems with pkg

Doug Hardie doug at
Thu Jul 21 06:50:43 UTC 2016

I have a recently installed 9.3 system that has been upgraded to the latest patches available with freebsd-update.  I tried to install postfix using pkg and here are the initial results.

Backup% uname -a
FreeBSD Backup 9.3-RELEASE-p43 FreeBSD 9.3-RELEASE-p43 #0: Sat May 28 00:19:32 UTC 2016     root at  amd64
Backup% su
Backup# pkg install postfix
Updating repository catalogue
digests.txz                         100% 2137KB   2.1MB/s   1.4MB/s   00:01    
packagesite.txz                     100% 5592KB   2.7MB/s   2.0MB/s   00:02    
pkg: package field incomplete: comment
Incremental update completed, 25142 packages processed:
21260 packages updated, 2245 removed and 3882 added.
pkg: Unable to find catalogs

At this point I tried it again and got:

Backup# pkg install postfix
Updating repository catalogue
The following 1 packages will be installed:

	Installing postfix: 2.11.1_1,1

The installation will require 13 MB more space

1 MB to be downloaded

Proceed with installing packages [y/N]: y
pkg:,1.txz: Not Found

I don't have this on other 9.3 systems.  How do I get around this?

— Doug

More information about the freebsd-questions mailing list