Found possible bug - how to report

Jørn Åne freebsd at
Tue Jul 5 09:12:36 UTC 2016

Hi, i'm fairly new to FreeBSD and i've never submitted a bugreport
before.  I think I found a bug but i'm not sure which component is to blame.

My setup is as follows:

I use winbind for user accounts, my /etc/nsswitch.conf has the following
group: winbind files
passwd: winbind files

The problem occurs in csh or tcsh.  When I run a program (not a shell
built-in command), the shell goes into a state that will cause it to
exit when I press ^C.  So for example:

% ^C
% which which
which: shell built-in command.
% ^C
% which whoami
% ^C
% whoami
% ^CConnection closed.

(^C isn't actually printed, I've added it for clarity)

This does not happen in sh-based shells, and it does not happen when I
change nsswitch back to dist.  This problem could be related to
tcsh/csh, nsswitch or samba.  I've tried ktrace, but i'm not that good
at reading the output of kdump, and i'm wary of posting the output here
since I don't understand what i'm actually sharing.

Any tips on how I can make a good bug report out of this would be
greatly appreciated!

Jørn Åne

More information about the freebsd-questions mailing list