How to make smooth USB access available to Virtualbox vm

Manish Jain bourne.identity at
Tue Jul 5 05:38:50 UTC 2016

On 07/05/16 06:16, Polytropon wrote:
> On Mon, 4 Jul 2016 23:35:25 +0000, Manish Jain wrote:
>> Hi,
>> I am running VirtualBox under FreeBSD 10.2 amd64. I created a Windows XP
>> vm for some work I need to do. The vm needs data which I placed on a USB
>> pen drive. I added a filter under VirtualBox to pass the pen drive to
>> the vm and then started the vm. The pen drive for some reason is not
>> smoothly visible to the vm - the icon for removable drive in the vm
>> keeps coming and going every 1-2 seconds. I think the problem is the
>> Gnome3 desktop environment and VirtualBox are competing for the USB pen
>> drive.
> Yes, that is to be expected as such a configuration tends to do lots
> of automount "magic" which is now turning against the user. :-)
>> On the host FreeBSD system, I repeatedly get error messages
>> "Unable to mount volume" - some error related to HALD. I tried setting
>> hald_enable="NO" in /etc/rc.conf and then rebooted FreeBSD.
> If I remember correctly, this doesn't have any effect, especially
> if you have gnome_enable="YES" defined.
>> Upon
>> restart, the situation remains the same - the vm does not see the pen
>> drive long enough for the data to be copied out.
> As far as I know, HAL - at the point where it was fully supported - has
> been EOL'd in Linux and is therefore mostly useless in FreeBSD. The
> problem you see probably is related to the Gnome 3 removable media
> subsystem, the "automounter". If you want to exclusively allow USB
> access to mass storage to the "Windows XP" VirtualBox instance, you
> need to disable that device inside Gnome, i. e. keep Gnome from trying
> to access it.
> Here is an instruction on how to do it (even though it is related to
> Ubuntu, it should work similarly on FreeBSD/VirtualBox):
> Allow me to quote the relevant text section:
> 	Select host USB device for access from the guest
> 	To grant access to USB devices we need to select a device to
> 	disable in the host and to enable in the guest (this is a
> 	precaution to avoid simultaneous access from host and guest).
> 	This can be done from the panel Devices menu or by right
> 	mouse click in the bottom panel of the Virtual Box Manager
> 	on the USB icon:
> 	(screenshot)
> 	Tick the device you need in the guest, untick it if you need
> 	it in the host. The selected device will immediately be
> 	accessible from the guest. A Windows guest may need additional
> 	drivers:

I tried both the Devices menu as well the bottom panel of Virtual Box 
Manager. It has no effect : the pen drive appears momentarily again and 
again - not long enough for me to copy out the data. I have also used 
dconf-editor to set to false 
- and in gnome3, the automount has stopped. But still vbox is unable to 
get clean access to the USB pen drive.

Is there anything else I can do ? I am further somewhat surprised that 
an extension pack which enables USB 2.0 access is available for Linux, 
but not for FreeBSD. Does anyone have any idea why is that so ?


Manish Jain

More information about the freebsd-questions mailing list