"fsck -y /" keeps saying "Disk is still dirty" no matter how many times I run it

markham breitbach markhamb at corp.ssimicro.com
Sat Jan 9 07:51:06 UTC 2016

On 2016-01-08 5:44 PM, jd1008 wrote:
> On 01/08/2016 05:15 PM, Lars Eighner wrote:
>> On Fri, 8 Jan 2016, Yuri wrote:
>>> As a result of the power outage I needed to run fsck on UFS disk
>>> with soft-updates.
>>> But every time the command 'fsck -y /' says that it corrected a lot
>>> of problems, but it still leaves the disk dirty. I ran it at least
>>> 15 times - same result.
>> Most likely you have a bad sector on your disk. fsck cannot fix this.
>> When you write to the disk, hopefully the disk will mark the sector
>> bad, and basically hide it. Unfortunately, you cannot mount it to
>> write if it is dirty. You can only newfs it, which means goodbye to
>> everything since your last backup. After you newfs, you can restore
>> from your backup.
>>> What would be the way to proceed from here?
>>> (I ran fsck before, but it never happened that fsck keeps finding
>>> problems)
>>> Thank you,
>>> Yuri
> Can you boot from a live fbsd cdrom and run fsck
> on the boot drive?
> Add the option -f -v
> Assuming your boot partition and slice is |ada0s1a
> |fsck -v -f -y /dev/|ada0s1a 2>&1 | tee /tmp/fsck.out|
> Please provide the file /tmp/fsck.out by uploading it to some sharing
> website, and provide the url to it.
> Be sure the drive in question is not mounted.

It is possible that there are problems with the controller.

Can you take the drive and put it into a completely different host? 
(Ideally as a secondary drive so you can boot without having to mount
the drive)


More information about the freebsd-questions mailing list