Is it possible to print to Canon Pixma MG2470 (USB) ?

Manish Jain bourne.identity at
Thu Feb 25 07:02:47 UTC 2016

On 02/25/16 03:34, Sergey Manucharian wrote:
> Hi Manish,
> Excerpts from Manish Jain's message from Thu 25-Feb-16 00:46:
>> Maybe a ppd file is needed for my printer, but googling fails to get any
>> suitable ppd file. Interestingly, gimp-gutenprint states that the printer is
>> supported. So what could I be missing ?
> Have you tried building the official driver from Canon web site?
> Or at list use the corresponding ppd form the same package?
> Here is the link:
> --
> Sergey

Thanks for your response. I downloaded the tarball and compiled the 
necessary cups filters for Canon MG2400. Here is what I now have in 
/usr/local/libexec/cups/filter :

/usr/local/libexec/cups/filter <<: ls
bannertopdf    gstoraster     pdftoopvp      pstops rastertohp     textonly
cmdtocanonij   gziptoany      pdftopdf       pstopxl rastertolabel  
commandtoescpx imagetopdf     pdftops        pstoraster rastertopclx   
commandtopclx  imagetops      pdftoraster    rastertodymo rastertopdf    
commandtops    imagetoraster  pstocanonij    rastertoepson rastertopwg
gstopxl        pdftoijs       pstopdf        rastertoescpx sys5ippprinter

When I try to print a test page or a text file, the printer blinks 1-2 
times and nothing happens.

Here a few lines from cups' error log :

E [25/Feb/2016:10:53:58 +0530] Missing <Job #> directive on line 27 of /var/db/cups/job.cache.
E [25/Feb/2016:11:00:28 +0530] [Client 2634] Returning IPP client-error-not-possible for Create-Printer-Subscriptions (/) from localhost
E [25/Feb/2016:11:01:40 +0530] c2470: File "/usr/local/libexec/cups/filter/pstocanonij" not available: No such file or directory
E [25/Feb/2016:11:27:50 +0530] [CGI] Unable to create service connection: No such file or directory
E [25/Feb/2016:11:27:50 +0530] [cups-deviced] PID 21771 (dnssd) stopped with status 1!
E [25/Feb/2016:11:33:02 +0530] [CGI] Unable to create service connection: No such file or directory
E [25/Feb/2016:11:33:02 +0530] [cups-deviced] PID 21812 (dnssd) stopped with status 1!

Then I tried using the cupsd.conf available at freebsd forums, with the result :

/usr/local/etc/cups <<: /usr/local/etc/rc.d/cupsd restart
WARNING: failed to start cupsd

The error log in /var has the following lines :
E [25/Feb/2016:12:23:04 +0530] Unknown directive BrowseAllow on line 15 of /usr/local/etc/cups/cupsd.conf.
E [25/Feb/2016:12:23:04 +0530] Unknown directive BrowseAddress on line 16 of /usr/local/etc/cups/cupsd.conf.
E [25/Feb/2016:12:23:04 +0530] Syntax error on line 49 of /usr/local/etc/cups/cupsd.conf.

Thanks for any further help.

Manish Jain

More information about the freebsd-questions mailing list