FreeBSD 10.2 :: IPv6 is not getting IP automatically

Shamim Shahriar shamim.shahriar at
Sun Feb 14 01:23:49 UTC 2016

Dear List Members

I posted this question to pfSense list as well -- since I am using a
pfSense router to connect to Hurricane Electric.

I followed the instructions from
So far it looks promising. I am supposed to get an IP from the router
box (I have configured a /48 network, assigned /64 to the LAN).

Now, as long as I connect a non-FreeBSD machine on the LAN side, it gets
an IPv6 address from the router. However, my FreeBSD 10.2 machine is not
getting anything.

# uname -a
FreeBSD osk.homenet 10.3-BETA1 FreeBSD 10.3-BETA1 #0 r295506: Thu Feb 11
11:30:22 GMT 2016     osk at osk.homenet:/usr/obj/usr/src/sys/osk  amd64

# ifconfig em0
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    ether f0:de:f1:d1:78:3c
    inet6 fe80::f2de:f1ff:fed1:783c%em0 prefixlen 64 scopeid 0x1
    inet netmask 0xffffffe0 broadcast
    media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active

# rtsol -D em0
checking if em0 is ready...
em0 is ready
set timer for em0 to 0s
New timer is 0s
timer expiration on em0, state = 1
send RS on em0, whose state is 2
set timer for em0 to 4s
New timer is 4s
received RA from fe80::20d:b9ff:fe35:c59e on em0, state is 2
OtherConfigFlag on em0 is turned on
Processing RA
ndo = 0x607b50
ndo->nd_opt_type = 3
ndo->nd_opt_len = 4
ndo = 0x607b70
ndo->nd_opt_type = 24
ndo->nd_opt_len = 3
ndo = 0x607b88
ndo->nd_opt_type = 25
ndo->nd_opt_len = 3
nsbuf = 2001:xxxx:xxxx::1
ndo = 0x607ba0
ndo->nd_opt_type = 31
ndo->nd_opt_len = 3
labellen = 11
dname = localdomain
ndo = 0x607bb8
ndo->nd_opt_type = 5
ndo->nd_opt_len = 1
ndo = 0x607bc0
ndo->nd_opt_type = 1
ndo->nd_opt_len = 1
rsid = [em0:slaac]
write to child = nameserver (11)
write to child = 2001:xxxx:xxxx::1(16)
write to child =
write to child = search (7)
write to child = localdomain(11)
write to child =  (1)
write to child =
script "/sbin/resolvconf" terminated
stop timer for em0
RA expiration timer: type=25, msg=2001:xxxx:xxxx::1, expire=19s
RA expiration timer: type=31, msg=localdomain, expire=19s
there is no timer

### relevant parts from /etc/rc.conf

ifconfig_em0_ipv6="inet6 accept_rtadv"

I have tried to add the following line as well

but that did not change anything.

So far I have tried removing the IPv4 related entries, setting up
deprecated options (just in case), checking to see if I have missed
anything in my kernel (nothing obvious came up), setting up an IP
manually. Of these, only the last (manual setup) appear to have worked
(i.e., I could communicate). I do not have any firewall running on this
machine (yet).

Given that I can connect to the same network using a Linux (Lubuntu)
system, get a v6 IP, get 10/10 from, makes me think that
the pfSense configuration is correct, and it is doing what it is
supposed to do (Just to be sure, I have restarted all the devices
several times, plugged devices in and out before/after restart, and so
on). However, apparently my FreeBSD 10.2 is not.

any suggestion / help / pointer is greatly appreciated.

thanks and regards

More information about the freebsd-questions mailing list