10.2 graphics problem

Glenn English ghe at slsware.net
Thu Sep 17 22:29:11 UTC 2015

OK. Some progress. I think I may have tried too hard. I was working from :A FreeBSD 10 Desktop How-to". I tried another install using just defaults (except for turning off games and turning on NTP). It almost works.

It will boot, run in a console (I don't think it switches from one workspace to another). And pkg xorg and pkg xfce work. And when I starxfce4, it comes up with the mouse and the keyboard working as expected. I can install widgets in the panel, the terminal emulator works.

But selecting logout in the menu drops XFCE as it should, but it drops to a completely blank screen with nothing paying any attention at mouse or screen. I tried ctl-n, ctl-alt-n, and just alt-n. Nothing.

After a reboot, I brought up X again, and typed, among some other things, ctl-alt-1, and X froze just like it did before.

I'm trying to get used to the way things are done in FreeBSD, and I truly believe it can all be done, but things doesn't work like they do in Debian. 

I can't even get a thumb-drive mounted. When I put one in, there's text saying that da0 and da0s1 have been noticed. If I type 'mount /dev/da0 /mnt', it says that /dev/da0 is an invalid param (or something like that). So I tried 'mount /dev/da0s1 /mnt'. Same error message. I looked at man, and it looked like a -t was what it was looking for, so I added -t msdosfs to the command IIRC, I got a different error message, but it didn't mount.

I don't have a problem with things being different, but the documentation on how to get this stuff working requires that I have it working to read the dox.

Does anyone know of an accurate set of instructions on the 'Net for a BSD install. Is there anything that really need editing after a really basic install (the one I just did had to download pkg when I tried to get xorg installed :-)

This is getting frustrating.

Glenn English

More information about the freebsd-questions mailing list