Installation progress

William A. Mahaffey III wam at
Mon Oct 19 20:33:53 UTC 2015

On 10/19/15 14:49, Steve O'Hara-Smith wrote:
> On Mon, 19 Oct 2015 14:34:38 -0453.75
> "William A. Mahaffey III" <wam at> wrote:
>> Well, I finally pulled the trigger on a ZFS install on my myth-TV
>> box-to-be and .... Everything basically worked, 2 glitches, but I got
>> worked around them & it is up & running, w/ 2X 1 TB 7200 RPM 2.5" HDD's
>> in an unmirrored pool, about 1.8 TiB total pool size. I am configuring
>> it now, & have a couple of questions. If I want it to be a NFS server &
>> export /home, do I just use that reference verbatim in my /etc/exports
>> file & crank the server or is there more to it ?
> 	You can do that, but just as ZFS has inbuilt support for managing
> mounting of filesystems by setting the mountpoint property it also has
> inbuilt support for managing NFS exports via the sharenfs property. Do one
> or the other - not both. I started out using /etc/exports and switched to
> ZFS properties for reasons I have now forgotten.

I just set sharenfs:

[root at mythbox, /etc, 3:25:23pm] 295 % df -h ; hddtemp /dev/ada[0-3] ; w 
; pstat -hms ; uname -a ; hwclock -r ; date
Filesystem          Type     Size    Used   Avail Capacity  Mounted on
zroot/ROOT/default  zfs      1.8T    450M    1.8T     0%    /
devfs               devfs    1.0k    1.0k      0B   100%    /dev
zroot/home          zfs      1.8T    208k    1.8T     0%    /home
zroot/tmp           zfs      1.8T    184k    1.8T     0%    /tmp
zroot/usr           zfs      1.8T    1.3G    1.8T     0%    /usr
zroot/usr/local     zfs      1.8T    9.3M    1.8T     0% /usr/local
zroot/var           zfs      1.8T    624k    1.8T     0%    /var
zroot/var/crash     zfs      1.8T    148k    1.8T     0% /var/crash
zroot/var/db        zfs      1.8T    3.1M    1.8T     0%    /var/db
zroot/var/db/pkg    zfs      1.8T     25M    1.8T     0% /var/db/pkg
zroot/var/empty     zfs      1.8T    144k    1.8T     0% /var/empty
zroot/var/log       zfs      1.8T    208k    1.8T     0%    /var/log
zroot/var/mail      zfs      1.8T    144k    1.8T     0% /var/mail
zroot/var/run       zfs      1.8T    216k    1.8T     0%    /var/run
zroot/var/tmp       zfs      1.8T    152k    1.8T     0%    /var/tmp
hddtemp: Command not found.
  3:25PM  up  5:29, 3 users, load averages: 0.00, 0.00, 0.00
USER       TTY      FROM                      LOGIN@  IDLE WHAT
root       v0       -                        11:09PM     - -csh (csh)
wam        pts/0    kabini1.local             2:45PM    26 -tcsh (tcsh)
wam        pts/1    kabini1.local             2:37PM     - w
Device          1M-blocks     Used    Avail Capacity
/dev/gpt/swap0      16384       0B      16G     0%
/dev/gpt/swap1      16384       0B      16G     0%
Total               32768       0B      32G     0%
FreeBSD mythbox 9.3-RELEASE FreeBSD 9.3-RELEASE #0 r268512: Thu Jul 10 
23:44:39 UTC 2014 root at  amd64
hwclock: Command not found.
Mon Oct 19 15:25:30 MCDT 2015
[root at mythbox, /etc, 3:25:30pm] 296 % zfs set sharenfs=on zroot/home
[root at mythbox, /etc, 3:25:45pm] 297 % zfs share -a

However, when I try to mount the shared 'directory', I get the following 
on the other box (also FreeBSD 9.3R, as it happens):

[wam at kabini1, ~, 3:33:43pm] 372 % lf /net/4256ee1/home/ 
/net/mythbox/home/  /net/q6600/home/; date
ls: /net/mythbox/home/: Operation timed out
FTP/     ISOs/    archive/ pub/     rsync/   wam/     work/

FTP/          ISOs/         VMs/          archive/ lost+found/   
mnt/          rsync/        wam/ work/         zaliases.csh
Mon Oct 19 15:34:02 MCDT 2015
[wam at kabini1, ~, 3:34:02pm] 373 %

& in my messages file:

Oct 19 15:19:40 kabini1 amd[31334]: get_mount_client failed for mythbox: 
: RPC: Program not registered
Oct 19 15:19:40 kabini1 amd[782]: /net/mythbox: mount (amfs_cont): 
Input/output error
Oct 19 15:20:33 kabini1 amd[31392]: get_mount_client failed for mythbox: 
: RPC: Program not registered
Oct 19 15:20:33 kabini1 amd[782]: /net/mythbox: mount (amfs_cont): 
Input/output error
Oct 19 15:27:47 kabini1 amd[31851]: get_mount_client failed for mythbox: 
: RPC: Program not registered
Oct 19 15:27:47 kabini1 amd[782]: /net/mythbox: mount (amfs_cont): 
Input/output error

Nothing in any of the log files on the myth-box. Pilot error, I'm sure, 
but any clues appreciated. Thanks & TIA & have a good one.

>> Also, is use of tmpfs
>> compatible/OK w/ ZFS 'filesystem' ?
> 	Sure no reason why you shouldn't use both, except perhaps for
> memory pressure.

Fair amount of RAM here (16 GB), so I think I'll activate tmpfs, thanks.


	William A. Mahaffey III


	"The M1 Garand is without doubt the finest implement of war
	 ever devised by man."
                            -- Gen. George S. Patton Jr.

More information about the freebsd-questions mailing list